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1 Getting Started

Microsoft Excel and MATLAB Interaction

Spreadsheet Link™ EX Add-In integrates the Microsoft® Excel® and
MATLAB® products in a computing environment running Microsoft®
Windows®. It connects the Excel® interface to the MATLAB workspace,
enabling you to use Excel worksheet and macro programming tools to leverage
the numerical, computational, and graphical power of MATLAB.

You can use Spreadsheet Link EX functions in an Excel worksheet or macro
to exchange and synchronize data between Excel and MATLAB, without
leaving the Excel environment. With a small number of functions to manage
the link and manipulate data, the Spreadsheet Link EX software is powerful
In its simplicity.

Note This documentation uses the terms worksheet and spreadsheet
interchangeably.

The Spreadsheet Link EX software supports MATLAB two-dimensional
numeric arrays, one-dimensional character arrays (strings), and
two-dimensional cell arrays. It does not work with MATLAB
multidimensional arrays and structures.



Microsoft® Excel® and MATLAB® Interaction

Microsoft Excel MATLAB
Excel work MATLA rk
xcel workspace [« Spreadsheet > B workspace
lnkex | T} f
Handle Simulink
Graphics
MATLAB
| Macro | | Worksheet | T—roes] [Compiler
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Installing the Spreadsheet Link EX Software
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In this section...

“System Requirements” on page 1-4

“Product Installation” on page 1-4

“Files and Folders Created by the Installation” on page 1-4
“Modifying Your System Path” on page 1-5

“After You Upgrade the Spreadsheet Link EX Software” on page 1-5

System Requirements

For information on hardware and software requirements for this product, see
http://www.mathworks.com/products/excellink/requirements.html.

Product Installation

Install the Microsoft Excel product before you install the MATLAB and
Spreadsheet Link EX software. To install the Spreadsheet Link EX Add-In,
follow the instructions in the MATLAB installation documentation. Select the
Spreadsheet Link EX check box when choosing components to install.

Note If you have several versions of MATLAB installed on your computer,
Spreadsheet Link EX software uses the version that you registered last.

Files and Folders Created by the Installation

Note Throughout this document the notation matlabroot is the MATLAB
root folder, the folder where the MATLAB software is installed on your system.

The Spreadsheet Link EX installation program creates a subfolder under
matlabroot\toolbox\. The exlink folder contains the following files:


http://www.mathworks.com/products/excellink/requirements.html

Installing the Spreadsheet Link™ EX Software

e excllink.xla: The Spreadsheet Link EX Add-In for Microsoft Excel 2003
and earlier versions

® excllink2007.xlam: The Spreadsheet Link EX Add-In for Microsoft Excel
2007 or 2010

® ExliSamp.xls: Spreadsheet Link EX example files described in this
documentation

The Spreadsheet Link EX software uses Kernel32.d11, which should
already be in the appropriate Windows system folder (for example,
C:\Winnt\system32). If not, consult your system administrator.

Modifying Your System Path

Add matlabroot\bin to your system path. For more information about
editing your system path, consult your Windows documentation or your
system administrator.

After You Upgrade the Spreadsheet Link EX Software

If MATLAB and Spreadsheet Link EX are installed on your computer, to
upgrade to a newer version:

1 Install the new version of MATLAB and the Spreadsheet Link EX software.
2 Start MATLAB and a Microsoft Excel session.
3 Configure the Spreadsheet Link EX software.

4 If you have existing workbooks with macros that use the Spreadsheet Link
EX software, update the references to the Spreadsheet Link EX software in
each workbook.

To update the references in an existing workbook in Microsoft Excel 2003 or
earlier versions:

1 In a Microsoft Excel session, open the Visual Basic® Editor window by
selecting Tools > Macros > Visual Basic Editor.

2 In the left pane, select a module for which you want to update a reference.

1-5
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3 From the main menu, select Tools > References.

4 In the References dialog box, select the SpreadsheetLinkEx check box.

5 Click OK.

To update the references in an existing workbook in Microsoft Excel 2007
or 2010:

1 In a Microsoft Excel session, open the Visual Basic Editor window by
clicking Visual Basic on the Developer tab. (If you do not find the
Developer tab, see the Excel Help.)

2 In the left pane, select a module for which you want to update a reference.
3 From the main menu, select Tools > References.

4 In the References dialog box, select the SpreadsheetLink2007 or
SpreadsheetLink2010 check box.

5 Click OK.
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Configuring the Spreadsheet Link EX Software

In this section...

“Configuring Microsoft® Excel 2003 and Earlier Versions” on page 1-7
“Configuring Microsoft® Excel 2007 and 2010” on page 1-9

“Setting Spreadsheet Link EX Preferences” on page 1-14

“Using Particular Versions of MATLAB” on page 1-15

“Working with the Microsoft® Visual Basic Editor” on page 1-15

Configuring Microsoft Excel 2003 and Earlier
Versions

To enable the Spreadsheet Link EX Add-In, start Microsoft Excel and follow
these steps:

1 Click Tools > Add-Ins. The Add-Ins dialog box appears.
2 Click Browse.

3 Select matlabroot\toolbox\exlink\excllink.xla.

Note Throughout this document the notation matlabroot is the MATLAB
root folder, the folder where the MATLAB software is installed on your
system.

4 Click OK.

In the Add-Ins dialog box, the Spreadsheet Link EX for use with
MATLAB check box is now selected.

5 Click OK to exit the Add-Ins dialog box.

The Spreadsheet Link EX Add-In loads now and with each subsequent Excel
session.

1-7
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The MATLAB Command Window button appears on the Microsoft
Windows taskbar.

i Startl J @ Microsaoft Excel | o\ MATLAE Command Window

The Spreadsheet Link EX toolbar appears on your Excel worksheet.

Start MATLAB
Function Wizard for
Spreadsheet Link EX

Start Execute MATLAB
command

MATLAB

Send data to Retrieve data
MATLAB from MATLAB

Import current
MATLAB figure

The Spreadsheet Link EX software is now ready for use.

4 Microsoft Excel - Book1
Bl Fle Edt  Wiew Insert |Format  Tools  Datp  Window  Hel
EFEHRYOISQIIVE & RH--INI-
J T d S A = (=21 Reply with Chang

A
startmatlab putmatrix getmatrix evalstring getfigure wizard preferences

Set MATLAB
Preferences
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Configuring Microsoft Excel 2007 and 2010

To enable the Spreadsheet Link EX Add-In, start a Microsoft Excel session
and follow these steps. If you use Microsoft Excel 2007:

Oin )
. )/ . .
1 Click —, the Microsoft Office Button.

2 Click Excel Options. The Excel Options dialog box appears.
If you use Microsoft Excel 2010:

1 Select File from the main menu.

2 Click Options. The Excel Options dialog box appears.

The next steps are the same for both versions:

3 Click Add-Ins.

4 From the Manage selection list, choose Excel Add-Ins.

5 Click Go. The Add-Ins dialog box appears.

6 Click Browse.

7 Select matlabroot\toolbox\exlink\excl1link2007.x1lam.

8 Click Open. In the Add-Ins dialog box, the Spreadsheet Link EX for use
with MATLAB check box is now selected.
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i s
Add-Ins available:
[ Analysis ToolPak - oK
[ Analysis ToolPak - VEA
Euro Currency Tools Cancel
[ Solver Add-in

Spreadsheet Link EX 3. 1.2 for use with MATLAB and Excel 20072010 Erowse

Automation...

Itk

Spreadsheet Link EX 3. 1.2 for use with MATLAB and Excel 20072010
Spreadsheet Link EX 3. 1.2 for use with MATLAB and Excel 20072010

9 Click OK to close the Add-Ins dialog box.

10 Click OK to close the Excel Options dialog box.

The Spreadsheet Link EX Add-In loads now and with each subsequent Excel
session.

The MATLAB Command Window button appears on the Microsoft
Windows taskbar.

The MATLAB group appears on the top right of the Home tab in your Excel
worksheet:
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= [=] =3
& 0 o & ©®
.J
Sort & Find &
Filter = Select -
_Editing || Start MATLAB
S5end data to MATLAE
O Get data from MATLAE

Run MATLAE command
Get MATLAE figure

MATLAE Function Wizard

Preferences

The Spreadsheet Link EX software is now ready for use.

Right-click a cell for MATLAB options. The following menu appears:
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Calibri ~ 11 -~ A" A7 % - %%

BI%&'&' .0 .00

- %

0 2.0

,@‘

:l Cut

By
=

i b

Copy
Paste Options:

Paste Special...

Insert...
Delete...

Clear Contents

Filter
Sort

Insert Comment

Format Cells...

Pick From Drop-down List...

Define Name...

Hyperlink...

MATLAE

Send data to MATLAE
et data from MATLAB
Run MATLAE command
Get MATLAE figure
Function Wizard

k
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Caution Using both the 2003 and 2007/2010 Add-Ins referenced in Excel
2007/2010 causes problems with the context-sensitive menu. Use only one
Add-In at a time to avoid this issue.
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Setting Spreadsheet Link EX Preferences

Use the Preferences dialog box to set Spreadsheet Link EX preferences. Click
the preferences button in the Excel toolbar or MATLAB group to open
this dialog box.

MATLAE Preferences @

[V iStart MATLAB at Excel startup

MATLAE startup folder

E ]

™ Use MATLAB desktop

[~ Show MATLAE errors

r Force use of MATLAE cell arrays with
MLPutMatrix

™ Treat missing/fempty cells as NaM

QK Cancel

Preferences include:
e Start MATLAB at Excel startup starts a MATLAB session automatically
when an Excel session starts. By default, this option is enabled.

e MATLAB startup folder lets you specify the startup folder for your
MATLAB session.

¢ Use MATLAB desktop starts the MATLAB desktop, including the current
folder, workspace, command history, and Command Window panes, when
an Excel session starts.

1-14
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* Show MATLAB errors displays MATLAB error messages in Excel
worksheet cells. Without this option, worksheet cells display Excel error
messages. See “Worksheet Cell Errors” on page 3-2.

* Force use of MATLAB cell arrays with MLPutMatrix enables the
MLPutMatrix function to use cell arrays for data transfer between the Excel
software and the MATLAB workspace.

* Treat missing/empty cells as NaN sets data in missing or empty cells to
NaN or zero.

Using Particular Versions of MATLAB

If there are several versions on MATLAB installed on your computer, the
Spreadsheet Link EX software uses the last registered version by default.
Typically, the last registered version is the latest version you have installed.
To choose a version of MATLAB other than the default one, use one of the

following approaches:

e Start that version of MATLAB as an automation server. For this, open
the DOS window, cd to the folder in which you want to start MATLAB,
and type matlab -automation at the DOS prompt. Then connect to that
(already running) MATLAB session. For details, see “Connecting to an
Existing MATLAB Session” on page 1-17.

¢ Change the last registered version to the version that you want to use.
To change the last registered version of MATLAB:

1 Shut down all MATLAB and Excel sessions.

2 Open a Command Prompt window, and using cd, change to the bin\win64
or bin\win32 subfolder of the MATLAB installation folder.

3 Enter the command.:
.\matlab /regserver
Working with the Microsoft Visual Basic Editor

Follow these steps to enable the Spreadsheet Link EX software as a Reference
in the Microsoft® Visual Basic® Editor:

1-15
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1 Open a Visual Basic session.

e [f you are running the Excel 2003 software, click
Tools > Macro > Visual Basic Editor.

¢ [f you are running the Excel 2007 or 2010 software, click the Visual

[
Basic button ( -1) on the Developer tab, or press Alt+F11.

Note For instructions how to display the Developer tab, see Excel Help.

2 In the Visual Basic toolbar, click Tools > References.

3 In the References — VBA Project dialog box, select the
SpreadsheetLinkEX check box.

4 Click OK.
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Starting and Stopping the Spreadsheet Link EX Software

In this section...

“Automatically Starting the Spreadsheet Link EX Software” on page 1-17
“Manually Starting the Spreadsheet Link EX Software” on page 1-17
“Connecting to an Existing MATLAB Session” on page 1-17

“Stopping the Spreadsheet Link EX Software” on page 1-19

Automatically Starting the Spreadsheet Link EX
Software

When installed and configured according to the instructions in “Configuring
the Spreadsheet Link EX Software” on page 1-7, the Spreadsheet Link EX
and MATLAB software automatically start when you start a Microsoft Excel
session.

Manually Starting the Spreadsheet Link EX Software

To start the Spreadsheet Link EX and MATLAB software manually from the
Excel interface:

1 Click Tools > Macro. (In Excel 2007, click the View tab or the Developer
tab, and then click the Macros button.)

2 Enter matlabinit into the Macro Name/Reference box.

For more information about the matlabinit function, see Chapter 4,
“Function Reference”.

3 Click Run. The MATLAB Command Window button appears on the
Microsoft Windows taskbar.

Connecting to an Existing MATLAB Session

To connect a new Excel session to an existing and already running MATLAB
session:

1 In MATLAB, enter the following command:

1-17
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enableservice('AutomationServer', true)

This command converts an existing MATLAB session into an Automation
server.

2 Start a new Excel session. It automatically connects to the running
MATLAB session.

Alternatively, you can start MATLAB as an automation server from the
beginning. To start MATLAB as an automation server, use the automation
command-line option:

matlab -automation

This command does not start MATLAB in a full desktop mode. To start
MATLAB in a full desktop mode, use the -desktop option:

matlab -automation -desktop

If you always use MATLAB as an automation server, modify the shortcut that
you use to start MATLAB:

1 Right-click your MATLAB shortcut icon. (You can use the icon on your
desktop or in the Windows Start menu.)

2 Select Properties.
3 Click the Shortcut tab.

4 Add the string -automation in the Target field. Remember to leave a
space between matlab.exe and /automation.

5 Click OK.

Note This option works only if the current MATLAB session is a registered
automation version. If not, the Excel software starts a new MATLAB session
rather than connecting to the existing one.
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Stopping the Spreadsheet Link EX Software

If you started the Spreadsheet Link EX and MATLAB software from the
Excel interface:

¢ To stop both the Spreadsheet Link EX and MATLAB software, close the
Excel session as you normally would.

¢ To stop the Spreadsheet Link EX and MATLAB software and leave the
Excel session running, enter the =MLClose () command into an Excel
worksheet cell. You can use the MLOpen or matlabinit functions to restart
the Spreadsheet Link EX and MATLAB sessions manually.

If you connected an Excel session to an existing MATLAB session, close Excel

and MATLAB sessions separately. Closing one session does not automatically
close the other.

1-19
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In this section...

“How Spreadsheet Link EX Functions Differ from Microsoft® Excel
Functions” on page 1-20

“Types of Spreadsheet Link EX Functions” on page 1-20
“Using Worksheets” on page 1-21
“Working with Arguments in Spreadsheet Link EX Functions” on page 1-23

“Using the MATLAB Function Wizard for the Spreadsheet Link EX
Software” on page 1-25

“Examples: Using Spreadsheet Link EX Functions in Macros” on page 1-30

How Spreadsheet Link EX Functions Differ from
Microsoft Excel Functions

¢ Spreadsheet Link EX functions perform an action, while Microsoft Excel
functions return a value.

® Spreadsheet Link EX function names are not case sensitive; that is,
MLPutMatrix and mlputmatrix are the same.

e MATLAB function names and variable names are case sensitive; that is,
BONDS, Bonds, and bonds are three different MATLAB variables.

Note Excel operations and function keys may behave differently with
Spreadsheet Link EX functions.

Types of Spreadsheet Link EX Functions

Spreadsheet Link EX functions manage the connection and data exchange
between the Excel software and the MATLAB workspace, without your
ever needing to leave the Excel environment. You can run functions as
worksheet cell formulas or in macros. The Spreadsheet Link EX software
enables the Excel product to act as an easy-to-use data-storage and



About Functions

application-development front end for the MATLAB software, which is a
powerful computational and graphical processor.

There are two types of Spreadsheet Link EX functions: link management
functions and data management functions.

Link management functions initialize, start, and stop the Spreadsheet Link
EX and MATLAB software. You can run any link management function other
than matlabinit as a worksheet cell formula or in macros. You must run
the matlabinit function from the Excel Tools > Macro menu, or in macro
subroutines.

Data management functions copy data between the Excel software and

the MATLAB workspace, and execute MATLAB commands in the Excel
interface. You can run any data management function other than MLPutVar
and MLGetVar as a worksheet cell formula or in macros. The MLPutVar and
MLGetVar functions can run only in macros.

For more information about Spreadsheet Link EX functions, see Chapter 4,
“Function Reference”.

Using Worksheets

Entering Functions into Worksheet Cells

Spreadsheet Link EX functions expect Al-style worksheet cell references;
that is, columns designated with letters and rows with numbers (the default
reference style). If your worksheet shows columns designated with numbers
instead of letters:

1 Click Tools > Options.
2 Click the General tab.

3 Under Settings, clear the R1C1 reference style check box.

Enter Spreadsheet Link EX functions directly into worksheet cells as
worksheet formulas. Begin worksheet formulas with + or = and enclose
function arguments in parentheses. The following example uses MLPutMatrix
to put the data in cell C10 into matrix A:

1-21
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=MLPutMatrix("A", C10)

For more information on specifying arguments in Spreadsheet Link EX
functions, see “Working with Arguments in Spreadsheet Link EX Functions”
on page 1-23.

Note Do not use the Excel Function Wizard. It can generate unpredictable
results.

After a Spreadsheet Link EX function successfully executes as a worksheet
formula, the cell contains the value 0. While the function executes, the cell
might continue to show the formula you entered.

To change the active cell when an operation completes, click Excel Tools
Options > Edit > Move Selection after Enter. This action provides a
useful confirmation for lengthy operations.

Automatic Calculation Mode Vs. Manual Calculation Mode
Spreadsheet Link EX functions are most effective in automatic calculation
mode. To automate the recalculation of a Spreadsheet Link EX function, add
to it a cell whose value changes. In the following example, the MLPutMatrix
function reexecutes when the value in cell C1 changes:

=MLPutMatrix("bonds", D1:G26) + C1

Note Be careful to avoid creating endless recalculation loops.

To use MLGetMatrix in manual calculation mode:

1 Enter the function into a cell.
2 Press F2.

3 Press Enter. The function executes.
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Spreadsheet Link EX functions do not automatically adjust cell addresses.
If you use explicit cell addresses in a function, you must edit the function
arguments to reference a new cell address when you do either of the following:

® Insert or delete rows or columns.

e Move or copy the function to another cell.

Note Pressing F9 to recalculate a worksheet affects only Excel functions.
This key does not operate on Spreadsheet Link EX functions.

Working with Arguments in Spreadsheet Link EX
Functions

This section describes tips for managing variable-name arguments and
data-location arguments in Spreadsheet Link EX functions.

Variable-Name Arguments
® You can directly or indirectly specify a variable-name argument in most
Spreadsheet Link EX functions:

= To specify a variable name directly, enclose it in double quotation marks;
for example, MLDeleteMatrix("Bonds").

= To specify a variable name as an indirect reference, enter it without
quotation marks. The function evaluates the contents of the argument to
get the variable name. The argument must be a worksheet cell address
or range name; for example, MLDeleteMatrix (C1).

Data-Location Arguments

® A data-location argument must be a worksheet cell address or range name.

® Do not enclose a data-location argument in quotation marks (except in
MLGetMatrix, which has unique argument conventions).

e A data-location argument can include a worksheet number; for example,
Sheet3!B1:C7 or Sheet2!OUTPUT.

1-23
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Note You can reference special characters as part of a worksheet name in
MLGetMatrix or MLPutMatrix by embedding the worksheet name within
single quotation marks ('").
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Using the MATLAB Function Wizard for the

Spreadsheet Link EX Software

The MATLAB Function Wizard for the Spreadsheet Link EX software allows
you to browse MATLAB folders and run functions from within the Excel

interface.

MATLAB Function Wizard

1. Select a category:

(3]

I matlablelmat - Elementary matrices and matrix manipj

2. Select a function:

Lpdate

tril

true

wander

3. Select a function signature:

TRIU(K)

TRIU( K
triu

Function Help:

Ll

TRIU Extract upper triangular part.
TRIU(X) is the upper triangular part of X,
TRIU(X,K) is the elements on and above the K-th diagonal of
¥, K =0is the main diagonal, K = 0 is above the main
diagonal and K < 0 is below the main diagonal.

See also TRIL, DIAG.

\_ o »

-
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You can use this wizard to:

1 Display a list of all MATLAB working folders and function categories.

All folders or categories in the current MATLABPATH display in the Select
a category field. Click an entry in the list to select it. Each entry in the
list displays as a folder path and a description read from the Contents.m
file in that folder. If no Contents.m file is found, the folder or category
display notifies you as follows:

finance\finsupport -(No table of contents file)
To refresh the folder/category list, click the Update button.

Select a particular folder or category, and list functions available for that
folder or category.

After you select a folder or category, the Select a function field displays
available functions for that folder or category. Click a function name to
select it.

Tip The Function Wizard does not allow you to access MATLAB
constructors and methods. You can write a wrapper function for a method
or a constructor and access that wrapper. See “Using the Function Wizard
to Access Custom MATLAB Functions” on page 1-28.

3 Select a function signature and enter a formula into the current

spreadsheet cell.

After you select a function, the Select a function signature field displays
available signatures for that function. Click a function signature to select it.

4 View help for the selected function.

The Function Help field displays help for the selected function.

When you click a function signature, the Function Arguments dialog box
appears.
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-

Function Argurments

TRIU

Inputs:

x |

Optional output cell(s): |

TRIU Extract upper triangular part.
TRILX) is the upper triangular part of X,

diagonal and K < 0 is below the main diagonal.

TRIUK,K) is the elements on and above the K-th diagonal of
¥. K =0is the main diagonal, K = 0 is above the main

CIK|

This dialog box allows you to specify the cells that contain input arguments
and the cells where to display outputs. By default, the output of the selected
function appears in the current spreadsheet cell using the Spreadsheet Link
EX function matlabfcn. In the following example, the output displays in the
current spreadsheet cell and generates a MATLAB figure:

=matlabfcn("plot",Sheet1!$B$2:$D$4)

Specifying a target range of cells using the Optional output cell(s) field in
the Function Arguments dialog box causes the selected function to appear in
the current spreadsheet cell as an argument of the matlabsub function. In

addition, matlabsub includes an argument that indicates where to write the
function’s output. In the following example, the data from A2 is input to the

rand function, whose target cell is B2:

=matlabsub("rand","Sheet1!$B$2",Sheet1!$A$2)

Tip Although the Function Wizard lets you specify multiple output cells, it
does not return multiple outputs. If you specify a range of output cells, the
wizard returns the first output argument starting in the first output cell.
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For example, if a function returns two separate elements a and b, and you
specify A1:A2 as output cells, the Function Wizard displays element a in
cell A1. It discards element b. If an output is a matrix, the Function Wizard
displays all elements of that matrix starting in the first output cell.

Using the Function Wizard to Access Custom MATLAB Functions
To access your custom MATLAB functions from the Function Wizard:

1 In MATLAB, create and save your function. For example, write the
function that computes the Fibonacci numbers and save it in the folder
Documents\MATLAB:

function f = fibonacci(n)
%FIBONACCI(N) Compute the Nth Fibonacci number.
% N must be a positive integer.
ifn<O0
error('Invalid number."')
elseif n ==
f =0;
elseif n ==
f=1;
else
f = fibonacci(n - 1) + fibonacci(n - 2);
end;
end

2 Add the folder where you saved the function to the MATLAB search path.
To add the folder to the search path, use the pathtool function or select
File > Set Path in the MATLAB desktop.

3 In Excel, open the MATLAB Function Wizard and select the folder where
you saved your function.
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MATLAB Function Wizard ==

1. Select a category:

I Documents{MATLAB - (Mo table of contents file) j Update |

2. Select a function:

fibonacc

3. Select a function signature:

FIBONACCI(N)
fibonacc

Function Help:

FIBOMACCI(M) Compute the Nth Fibonacd number,
M must be a positive integer.

Ok |

The Function Wizard does not allow you to access MATLAB constructors
and methods. To be able to access a method or a constructor from the
Function Wizard, write a wrapper function for that method or constructor.
For example, to access the timeseries (DATA) constructor from the Function
Wizard, write the following wrapper function:
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function TS = timeseries_wrapper (DATA)

% timeseries_wrapper (DATA) is a wrapper function

for TIMESERIES (DATA)
TS = TIMESERIES(DATA) creates a time series object TS using
data DATA. By default, the time vector ranges from 0 to N-1,
where N is the number of samples, and has an interval of 1
second. The default name of the TS object is 'unnamed'.

d® o® ° o° of

o°

T = timeseries(DATA);
TS = T.data;
end

Examples: Using Spreadsheet Link EX Functions in
Macros

About the Examples

This section contains examples that show how to manipulate MATLAB data
using Spreadsheet Link EX.

¢ For an example of how to exchange data between the MATLAB and Excel
workspaces, see “Importing and Exporting Data Between the Microsoft®
Excel Interface and the MATLAB Workspace” on page 1-33.

¢ For an example of how to export data from the MATLAB workspace and
display it in an Excel worksheet, see “Sending MATLAB Data to an Excel
Worksheet and Displaying the Results” on page 1-30.

Sending MATLAB Data to an Excel Worksheet and Displaying
the Results

In this example, you run MATLAB commands using VBA, send MATLAB
data to the Excel software, and display the results in an Excel dialog box.

1 Start an Excel session.

2 Initialize the MATLAB session by clicking the startmatlab button in the
Spreadsheet Link EX toolbar or by running the matlabinit function.

3 If the Spreadsheet Link EX Add-In is not enabled, enable it.
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¢ For instructions on enabling this Add-In for the Excel 2003 software, see
“Configuring Microsoft® Excel 2003 and Earlier Versions” on page 1-7.

¢ For instructions on enabling this Add-In for the Excel 2007 software, see
“Configuring Microsoft® Excel 2007 and 2010” on page 1-9.

4 Enable the Spreadsheet Link EX software as a Reference in the Microsoft
Visual Basic Editor. For instructions, see “Working with the Microsoft®
Visual Basic Editor” on page 1-15.

5 In the Visual Basic Editor, create a module.

a Right-click the Microsoft Excel Objects folder in the Project —
VBAProject browser.

b Select Insert > Module.

6 Enter the following code into the module window:

Option Base 1
Sub Method1 ()

MLShowMatlabErrors "yes"

"''To MATLAB:

Dim Vone(2, 2) As Double "Input
Vone(1, 1) =1

Vone(1, 2) = 2

Vone(2, 1) = 3

Vone(2, 2) = 4

MLPutMatrix "a", Range("A1:B2")
MLPutVar "b", Vone
MLEvalString ("c = a*b")
MLEvalString ("d = eig(c)")

"'*'"From MATLAB:

Dim Vtwo As Variant "Output
MLGetVar "c", Vtwo

MsgBox "c is " & Vtwo(1, 1)
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MLGetMatrix "b", Range("A7:B8").Address
MatlabRequest

MLGetMatrix "c", "Sheet1!A4:B5"
MatlabRequest

Sheets("Sheet1").Select
Range("A10").Select

MLGetMatrix "d", ActiveCell.Address
MatlabRequest

End Sub

Tip Copy and paste this code into the Visual Basic Editor from the HTML
version of the documentation.

7 Run the code. Press F5 or click Run > Run Sub/UserForm.

The following dialog box appears.

Microsoft Excel @

-

cisl

8 Click OK to close the dialog box.

Note Do not include MatlabRequest in a macro function unless the macro
function 1s called from a subroutine.




Working with Dates

Tip In macros, leave a space between the function name and the first
argument; do not use parentheses.

Importing and Exporting Data Between the Microsoft Excel
Interface and the MATLAB Workspace

¢ This example uses MLGetMatrix in a macro subroutine to export data from
the MATLAB matrix A into the Excel worksheet Sheet1.

Sub Test1()
MLGetMatrix "A", "Sheet1!A5"
MatlabRequest

End Sub

Note The MatlabRequest function initializes internal Spreadsheet Link
EX variables and enables MLGetMatrix to function in the subroutine.

® This example uses MLPutMatrix in a macro subroutine to import data into
the MATLAB matrix A, from a specified cell range in the Excel worksheet
Sheet1.

Sub Test2()
Set myRange = Range("A1:C3")
MLPutMatrix "A", myRange

End Sub

Working with Dates

Default Microsoft Excel date numbers represent the number of days that have
passed since January 1, 1900. For example, January 1, 1950 is represented as
18264 in the Excel software.

However, MATLAB date numbers represent the number of days that have

passed since January 1, 0000, so January 1, 1950 is represented as 712224
in the MATLAB software. Therefore, the difference in dates between the
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Excel software and the MATLAB software is a constant, 693960 (712224
minus 18264).

To use date numbers in MATLAB calculations, apply the 693960 constant as
follows:
e Add it to Excel date numbers that are read into the MATLAB software.

e Subtract it from MATLAB date numbers that are read into the Excel
software.

Note If you use the optional Excel 1904 date system, the constant is
695422.

Dates are stored internally in the Excel software as numbers and are
unaffected by locale.



Localization Information

Localization Information

This document uses the Microsoft Excel software with an English (United
States) Microsoft Windows regional setting for illustrative purposes. If you
use the Spreadsheet Link EX software with a non-English (United States)
Windows desktop environment, certain syntactical elements may not work as
illustrated. For example, you may have to replace the comma (,) delimiter
within Spreadsheet Link EX commands with a semicolon (;) or other operator.

Please consult your Windows documentation to determine which regional
setting differences exist among non-U.S. versions.
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Solving Problems with
the Spreadsheet Link EX
Software

¢ “Modeling Data Sets Using Data Regression and Curve Fitting” on page 2-2
¢ “Interpolating Data” on page 2-11
® “Pricing Stock Options Using the Binomial Model” on page 2-15

e “Calculating and Plotting the Efficient Frontier of Financial Portfolios”
on page 2-19

e “Mapping Time and Bond Cash Flows” on page 2-24
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Modeling Data Sets Using Data Regression and Curve

Fitting

In this section...

“Using Worksheets” on page 2-2
“Using Macros” on page 2-6

Regression techniques and curve fitting attempt to find functions that
describe the relationship among variables. In effect, they attempt to build
mathematical models of a data set. MATLAB matrix operators and functions
simplify this task.

This example shows both data regression and curve fitting. It also executes
the same example in a worksheet version and a macro version. The
example uses Microsoft Excel worksheets to organize and display the data.
Spreadsheet Link EX functions copy the data to the MATLAB workspace, and
then executes MATLAB computational and graphic functions. The macro
version also returns output data to an Excel worksheet.

This example is included in the Spreadsheet Link EX product. To run it:
1 Start Excel, Spreadsheet Link EX, and MATLAB sessions.

2 Navigate to the folder matlabroot\toolbox\exlink\.

3 Open the file Ex1iSamp.x1ls

4 Execute the example as needed.

Using Worksheets

1 Click the Sheetl tab on the Ex1iSamp.x1ls window. The worksheet for
this example appears.
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1
2
3
4
5
B
T
i
9
10
11
12
13

14
15
16
17
18
19
20
21
22
23
24
25
26
27
28

A B C D E F G H J K L
Regression and Curve Fitting
DATA Spreadsheet Link EX Functions

35 207 1325 1. Transfer the data to MATLAB.

17 90 533 #MATLAB? <== MLPutMatrix("data".DATA)

43 180 1013

41 187 1163 2. Set up data for regression.
177 552 5326 #MATLAB? <== MLEvalString("y = data(:,3)")

a7 354 2043 #MATLAB? <== MLEvalString("e = ones(length(data),1)")

20 101 602 #MATLAB? <== MLEvalString("A = [e data(:.1:2)]")

18 91 532

17 86 543 3. Compute regression coefficients.

35 180 1134 #MATLAB? <== MLEvalString("beta = Aly")

25 136 766

17 84 495 4. Calculate regressed result.

23 102 635 #MATLAB? <== MLEvalString("fit = A*beta")

24 148 913

40 292 1591 5. Compare original data with regression results.

25 126 671 #MATLAB? <== MLEvalString("[y.k] = sortiy)")

17 88 51 #MATLAB? <== MLEvalString("fit = fit(k)")

46 235 1319 #MATLAB? <== MLEvalString("n = size(data,1)")

3T 204 1038

15 68 458 6. Use MATLAB's polynomial solving functions for anather curve fit.
85 363 2904 #MATLAB? <== MLEvalString("[p.S] = polyfit{1:n,y",5)")

66 300 2006 #MATLAB? <== MLEvalString("newfit = polyval(p,1:n,5)")

39 161 938
111 459 3282 7. Plot curves and add legend

16 80 476 #MATLAB? <== MLEvalString("plot(1:n,y.'p0" 1:n.fit. 7", 1:n,newfit.'q’): legend(data’,fit’, newfit’)")

The worksheet contains one named range: A4:C28 is named DATA and
contains the data set for this example.

2 Make E5 the active cell. Press F2; then press Enter to execute the
Spreadsheet Link EX function that copies the sample data set to the
MATLAB workspace. The data set contains 25 observations of three
variables. There is a strong linear dependence among the observations; in
fact, they are close to being scalar multiples of each other.

3 Move to cell E8 and press F2; then press Enter. Repeat with cells E9 and
E10. These Spreadsheet Link EX functions regress the third column of data
on the other two columns, and create the following:

® A single vector y containing the third-column data.

¢ A three-column matrix A, that consists of a column of ones followed by
the rest of the data.
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2-4

4 Execute the function in cell E13. This function computes the regression

coefficients by using the MATLAB back slash (\) operation to solve the
(overdetermined) system of linear equations, A*beta = y.

5 Execute the function in cell E16. MATLAB matrix-vector multiplication

produces the regressed result (fit).

6 Execute the functions in cells E19, E20, and E21. These functions do the

following:
a Compare the original data with fit.
b Sort the data in increasing order and apply the same permutation to fit.

¢ Create a scalar for the number of observations.

7 Execute the functions in cells E24 and E25. Often it is useful to fit a

polynomial equation to data. To do so, you would ordinarily have to set up
a system of simultaneous linear equations and solve for the coefficients.
The MATLAB polyfit function automates this procedure, in this case for a
fifth-degree polynomial. The polyval function then evaluates the resulting
polynomial at each data point to check the goodness of fit (newfit).

8 Execute the function in cell E28. The MATLAB plot function graphs the

original data (blue circles), the regressed result fit (dashed red line), and
the polynomial result (solid green line). It also adds a legend.
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Figure1 E=N Bl =X
File Edit View Inset Tools Desktop Window Help &
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6000 . . . .
2 data
"""" fit K
5000 newfit
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Since the data is closely correlated but not exactly linearly dependent, the

fit curve (dashed line) shows a close, but not an exact, fit. The fifth-degree
polynomial curve, newfit, is a more accurate mathematical model for the data.

When you finish this version of the example, close the figure window.
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Using Macros

1 Click the Sheet2 tab on Ex1iSamp.x1s. The worksheet for this example
appears.

A B C D
Regression and Curve Fitting Macro
(See Module 1)
0 === CunveFit(DATA "AT" "BT","CT")

y fit newfit
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2 Make cell A4 the active cell, but do not execute it yet.

Cell A4 calls the macro CurveFit, which you can examine in the Microsoft
Visual Basic environment.

E Microseft Visual Basic for Applications - ExliSamp.xls EI@
! File Edit View Inset Format Debug Run  Tools Add-Ins  Window Help Type a question for help -
EE-EJd 4 0L A bou @k BFW o @ Ln2cal B

Project - ExliSamp x|

#2 ExliSamp.xls - Modulel (Code) o -E | ]

|:General] ﬂ |:Declarations] ﬂ

E E 3 B
E@ ExliSamp (ExliSamp.xls)

-3 Microsoft Excel Objects [a]
i Sheet1 (Sheet1)
Sheet2 (SheetZ)
Sheet3 (Sheet3) Function CurveFit (aData, sTargetl, sTarget2, sTarget3)
Sheet4 (Sheetd) "MATLAER regression and curve fitting macro
Sheet5 (Sheets)
Sheets (Sheets) MLPutMatrix "data", aData
ThisWarkbook MLEvalString "y = data(:,3)"
B3 Modules MLEvalString "n = length(y)"
il Modulel MLEvalString "e = cgnes(n,1)"
(77 References MLEvalString "A = [e data(:,1:2)]"
&8} Spreadsheetlink2007_2010 MLEvalString "beta = B\y"
MLEvalString "fit = A*beta"
4 |+ b MLEvalS3tring "[v,k] = sortiy)"™
MLEwvalString "fit = fit(k)"
Properties - Modulel x| MLEvalString "[p, 5] = polyfit(l:n,v',5)"
|M0,dulel Madule j MLEvalString "newfit = polyval(p,l:n,5)'"

MLEvalS3tring "plot{l:n,vy,'bo',l:n,fit,'r:',1l:n,newfit, 'g'
MLGetMatrix "y", sTargetl

MModulel MLGetMatrix "fit", sTarget2

MLGetMatrix "newfit", sTarget3

Alphabetic l Categorized I

End Function

3 While this module is open, make sure that the Spreadsheet Link EX add-in
1s enabled.

¢ If you are using the Excel 2003 software:

a Click Tools > References.
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b In the References dialog box, make sure that the excllink.xla check
box is selected. If not, select it.

¢ Click OK.
¢ [f you are using the Excel 2007 software:

|'I."-|'
d Click the Microsoft Office Button, “

L

e Click Options. The Excel Options pane appears.

f Click Add-Ins.

g From the Manage selection list, choose Excel Add-Ins.
h Click Go. The Add-Ins pane appears.

i Make sure that the Spreadsheet Link EX for use with MATLAB
check box is selected. If not, select it.

[ Add-Ins @

Add-Ins available:

[] Analysis ToolPak - oK
[T Analysis ToolPak - vBA

|:| Euro Currency Tools
[] solver Add-in

-

Cancel

Spreadsheet Link EX 3.1. 2 for use with MATLAB and Excel 2007/2010

Browse...

rHke

Automation...

Spreadsheet Link EX 3. 1.2 for use with MATLAB and Excel 2007/2010
Spreadsheet Link EX 3. 1.2 for use with MATLAB and Excel 20072010
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i Click OK to close the Add-Ins pane.
k Click OK to close the Excel Options pane.

4 In cell A4 of Sheet2, press F2; then press Enter to execute the CurveFit
macro. The macro does the following:

a Runs the same functions as the worksheet example (in a slightly
different order), including plotting the graph.

b Calls the MLGetMatrix function in the CurveFit macro. This macro
copies to the worksheet the original data y (sorted), the corresponding
regressed data fit, and the polynomial data newfit.
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A B C D
Regression and Curve Fitting Macro
(See Module 1)

0 === CurveFit[DATA,"AT","BT","CT")

y fit newfit
1325 | 379.0475] 402.008
b33 430.3099 | 515.8528
1013 | 462.4722 | 549.7114
10 1163 | 472.0222 | 543.0184
11 5326 | 501.7971] 524.5495
12 2043 | 476.7973| 513.775
13 602 467.2472 | 522 2081
14 532 570.8968 | 554.761
15 543 641.1212 | 611.0947
16 1134 | 743.6461 | B686.9715
17 766 TE7.5211 | 775.6072
18 495 773.5589 | 869.023
19 635 1143.781 | 959.3574
20 913 1279.593 | 1040.419
21 1591 | 1201.2159] 1108.636
22 671 1098.695 | 1164.812
23 s 1251.081 | 1215.276
24 1319 | 1478743 | 1273.275
25 1038 | 1163.157 | 1360.322
26 458 1479157 | 1507.557
27 2904 | 2086177 | 1757.09
23 2006 |2011.592|2163.358
29 938 2666.224 | 2794 475
30 3282 | 3483.345|3733.586
31 476 5197.796 | 5080.215
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Interpolating Data

Interpolation is a process for estimating values that lie between known data
points. It is important for applications such as signal and image processing

and data visualization. MATLAB interpolation functions let you balance the
smoothness of data fit with execution speed and efficient memory use.

This example is included in the Spreadsheet Link EX product. To run it:

1 Start Excel, Spreadsheet Link EX, and MATLAB sessions.
2 Navigate to the folder matlabroot\toolbox\exlink\.
3 Open the file Ex1iSamp.x1ls

4 Execute the example as needed.

This example uses a two-dimensional data-gridding interpolation function
on thermodynamic data, where volume has been measured for time

and temperature values. It finds the volume values underlying the
two-dimensional, time-temperature function for a new set of time and
temperature coordinates.

The example uses a Microsoft Excel worksheet to organize and display the
original data and the interpolated output data. You use Spreadsheet Link
EX functions to copy the data to and from the MATLAB workspace, and then
execute the MATLAB interpolation function. Finally, you invoke MATLAB
graphics to display the interpolated data in a three-dimensional color surface.

1 Click the Sheet3 tab on Ex1iSamp.x1s. The worksheet for this example
appears.
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2-12

) =] =
Data Interpolation
Original Data
Time Temp Volume

0025 6300 2504.03

00s0 BE05 253507

0075 B30T 256291

0100 6303 257574

0125 6320 260616

0150 6350 2628.53

01vs 68385 268138

0200 6322 271208

0225 7008 276752

0250 7033 251554

0275 7053 2824.37

0300 065 257365

0.325 TN 2E3z.20

0.350 144 2536.43

0.375 T8z z2anz.ov

0400 7233 232004

0425  T265 232335

0450 7346 2334.23

0475 7385 2335855

0500 7422 301293

0525 7437 303312

0550 7455 313001

0575 7467 317324

0600 74¥2 313071

0625 7500 313475

Interpolated Values

Temp
Time B&.0 B85 53.0 B35 J0.0 it} .0 k) i) 725 il Fich-) 4.0 4.5

750

0.025)
0.05
0.075)
0.1
0,125
0.15
0175
0.2
0.225)
0.25)
0.275)
0.3
0.325)
0.35
0,375
0.4
0.425)
10.45)
0.475)
0.5
0.525)
0.55
0.575
(.5

Spreadsheet Link EX Functions

1. Transfer ariginal data o MATLAB.

HMATLAE <== MLPutMatriu["Labels”, Ad:Cd]
#MATLAE <== MLPutMatria["".A5:A23]
HMATLAE <== MLPutMatria["T" B5:E23)
HMATLAE <== MLPutMatrin["y",C5:C231

2. Transfer interpalation data paints to MATLAB.
#MATLAE <== MLPutMatrin("xa" ET:E30)
HMATLAE <== MLPutMatrix["Ta".F6: TE)

3. Execute MATLAB data interpolation function.
#MATLAE <== MLEvalStringl "%, TI, VIl = griddatal.T.\ xa.Ta, inudist’]"]

4. Transpose output data matrix and transfer data to Excel,
HMATLAE <== MLEwalStringl("lV' = V11"
HMATLAE <== MLGetMatria"V" "sheet3IFT"]

5. Platinterpolated data and label the figure.
HMATLAE <== MLEwalString("surf(x, T, W tide(Interpolated Data’);ulabelll abels {1 vlabel(L abelsi2t); zlabellL abel=i3t); arid on]

The worksheet contains the measured thermodynamic data in cells A5:A29,
B5:B29, and C5:C29. The time and temperature values for interpolation
are in cells E7:E30 and F6:T6, respectively.

2 Make A33 the active cell. Press F2; then press Enter to execute the
Spreadsheet Link EX function that passes the Time, Temp, and Volume
labels to the MATLAB workspace.

3 Make A34 the active cell. Press F2; then press Enter to execute the
Spreadsheet Link EX function that copies the original time data to the
MATLAB workspace. Move to cell A35 and execute the function to copy the
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Time

0.025)
0.05)
0.075)
0.1
0.125
0.15]
0.175
0.2
0.225)
0.25)
0.275)
0.3
0.325)
0.35)
0.5375)
0.4
0.425)
0.45)
0.475)
0.5
0.525)
0.55)
0.575)
0.6

original temperature data. Execute the function in cell A36 to copy the
original volume data.

4 Move to cell A39 and press F2; then press Enter to copy the interpolation
time values to the MATLAB workspace. Execute the function in cell A40 to

copy the interpolation temperature values.

5 Execute the function in cell A43. griddata is the MATLAB two-dimension
interpolation function that generates the interpolated volume data using
the inverse distance method.

6 Execute the functions in cells A46 and A47 to transpose the interpolated
volume data and copy it to the Excel worksheet. The data fills cells F7:T3
which are enclosed in a border.

Interpolated Yalues

Temp
535.0

58.5

53.0 53.5 0.0 0.5 1.0 1.5 7z.0 725 730 T35 7d.0 7.5

al

0,

5.0

2504.03
2507.26
2510.83
2513.93
2515.14
251431
2511.84
250810
250337
2437.54
243166
2454.32
247771
2470.07
2452, 06
2453.70
2445.03
2436.07
2426.82
241731
2407.54
2337.51
2387.29
2376.71

263815
2635.76
263345

263134
2623.60
2628.55
Z628.85

262391

263132
263293
26734.64
2636.35
2638.00
26339.54
264033

264215

264315
264334
2644.45
2644. 77
Z2644.80
2644.56
2644.05
264325

270732 275003 278431 2851713 29162 Z2340.67 236140 233317 F000.06 300632 304101 312578 302
2704.73 274666 277996 =254G6.35 =2307.00 233495 235507 2376.65 2333.64 2333.35 303443 312643 303
270258 274362 277540 Z8d18d 230275 232364 234303 237051 Z38V.50 233260 30Z7.93 312637 304
2700.70 274033 277127 283766 =2535.65 232466 234343 2364.66 235167 2356.05 302143 3127.33 309
2683317 273877 ZVET.E1 2833.83 283540 232007 233814 239374 297616 237383 35068 F1EV.71 306
2635.02 2736.33 2764.43 253035 285231 =2515.87 233323 2355.97 237053 237386 3004.70 3127.35 307
Z2B37.25 ZT35.66 ZTE2.00 282731 2893.53 231203 232872 234317 236617 296521 300247 F12811 308

6.55)
565
B.32)
57T
5.02)
4. 05
2,33

2BI6.67 2734.79 276022 252468 =587.26 2308.72 232462 2344.75 236171 236253 2336.33 F125.21 309157

ZB36.88 273437 275924 282257 2885.23 2305.80 232036 2340.73 Z35V.65 2957.93 233050 312825 309

3,39

263726 273442 279990 282105 255365 2303.34 291776 233713 2953.97 2353.56 2354.50 F128.24  FW05.13
2638.05 273431 Z¥S5.76 282023 288243 230133 Z915.02 2333.97 235071 23d43.20 297352 F1EE.18 3604

263916 273565 276112 282016 =585155 283373 231275 233126 23d47.856 234545 2374.53 312807 S22

3,63

270064 273722 ZYE3.09 282081 285106 2838.7Z 23104 2323.03 234547 234221 2963.96 312730 313126

270241 2735.01 2¥65.53 282211 268097 283813 230982 2327.23 2345352 233343 236583 312766 15

i3.35)

270445 274113 ZYE8.5d 252398 285123 28383.00 230313 2326.05 234201 293716 296233 F1ZV.30 0 314513
2TOE.7S 274375 277183 2526.33 =2852.03 2838.34 230897 2325.33 2340.96 233542 2353.55 3F126.73 315166

270326 ZT4E.E6T 277562 282313 2883.20 253316 230334 232574 Z3d40.57 2334.25 235745 312607 319
27197 274392 2TTI68 283232 286475 290044 231023 2525.45 2340.24 233367 235616 312503 16
271484 275348 27406 283583 288678 230213 2963 2326.534 234057 233371 235574 312385 316

7.7
3,42
3.63)

271784 2¥57.532 2TH6.T3 283378 258313 2304.40 231352 232771 294136 2334.34 2356.22 12246 317331

272095 Z7E1dd ZYI36T 284401 285193 2307.04 231583 2323.57 234261 233555 E235V.60 FE21ET ST
272414 2¥65.73 2TI5.87 284855 283513 23101 231872 2331.890 2344.30 2337.30 235385 3120088 315

.39
0.7

272733 277037 280431 285338 £838.77 23360 232133 Z2334.68 234643 Z333.57 296283 FE1LEI 318327

273067 277514 2805.87 255543 250271 =2517.48 232567 2337.63 2945.593 234235 2366.66  F123.41 315

.53

7 Execute the function in cell A50. The MATLAB software plots and labels
the interpolated data on a three-dimensional color surface, with the color
proportional to the interpolated volume data.
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Figurel
File Edit View Insert Tools

Ddde | | ARKTDE M- | 0E 1|

Interpolated Data

Desktop  Window  Help

Wolume

St
Temp 0 Tirre

When you finish the example, close the figure window.
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Pricing Stock Options Using the Binomial Model

The Financial Toolbox™ product provides functions that compute prices,
sensitivities, and profits for portfolios of options or other equity derivatives.
This example uses the binomial model to price an option. The binomial
model assumes that the probability of each possible price over time follows a
binomial distribution. That is, prices can move to only two values, one up or
one down, over any short time period. Plotting these two values over time is
known as building a binomial tree.

This example organizes and displays input and output data using a Microsoft
Excel worksheet. Spreadsheet Link EX functions copy data to a MATLAB
matrix, calculate the prices, and return data to the worksheet.

This example is included in the Spreadsheet Link EX product. To run it:
1 Start Excel, Spreadsheet Link EX, and MATLAB sessions.

2 Navigate to the folder matlabroot\toolbox\exlink\.

3 Open the file Ex1iSamp.x1ls

4 Execute the example as needed.

Note This example requires Financial Toolbox, Statistics Toolbox™, and
Optimization Toolbox™.,

1 Click the Sheet4 tab on Ex1iSamp.x1s to open the worksheet for this
example.
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A B C D E F G H J K

Binomial Option Pricing
bindata Spreadsheet Link EX Functions

Asset price, so 5 52.00 1. Transfer data to MATLAB.
Option exercise price, x | $ 50.00 #MATLAB' === MLPutMatrix("b", bindata)
Riskfree interest rate, r 10%
Time to maturity, t (yrs) | 0.416667|=5/12 2. Execute MATLAB Financial Toolbox binomial option pricing function.
Time increment, dt 0.083333|=112 #MATLAB' <== MLEvalString("[p. o]=binprice(b(1)., b(2), b(3). b(4), b(5). b(6), b(7))"}
WVolatility, sig 0.4
Call (1) or put (0}, flag 0 3. Transfer output data to Excel.

#MATLAB' === MLGetMatrix("p", "asset_tree"}
#MATLAB <== MLGetMatrix("0", "value_tree")

Start Period 1 Period 2 Period 3 Period4  Period &

Asset price tree, p ($)

Option value tree, o ($

malMamIRa M MMM N R aalala A=
i A S N A S E R S P I = il el e il Bl e e

The worksheet contains three named ranges:

® B4:B10 named bindata. Two cells in bindata contain formulas:
- B7 contains =5/12
- B8 contains =1/12

® B15 named asset_tree.

® B23 named value_tree.

2 Make D5 the active cell. Press F2; then press Enter to execute the
Spreadsheet Link EX function that copies the asset data to the MATLAB
workspace.

3 Move to D8 and execute the function that computes the binomial prices.
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[F=20 = RN = R A RIFESR FURY %

4 Execute the functions in D11 and D12 to copy the price data to the Excel

A
Binomial Option Pricing

worksheet.

The worksheet looks as follows.

Asset price, so

Option exercise price, X
Risk-free interest rate, r
Time to maturity, t (yrs)
Time increment, dt
Volatility, sig

Call (1) or put {0}, flag

Asset price tree, p ($)

Option value tree, o ($

B C D E F G H
bindata Spreadsheet Link EX Functions
5 5200 1. Transfer data to MATLAB.
5 50.00 0 «<== MLPutMatrix("b", bindata)
10%
0.416667|=5/M12 2. Execute MATLAB Financial Toolbox binomial option pricing function.
0.083333|=112 0 === MLEvalString("[p, o]=binprice(b(1), b{2). b(3), b{4). b(5), b{E), B(T))")
0.4
0 3. Transfer output data to Excel.
0 === MLGetMatrix("p". "asset_tree")
0 === MLGetMatrix("0", "value_tree"}
Start  Period 1 Period 2 Period 3 Period 4 Period &
52000 5B.365 65509 73527  B2527T 92628
0 46329 52000 5B.365  B5EADY  T3AZT
0 0 M277 46329 52000  58.365
0 0 0 36776 41277 46.329
0 0 0 0 32765 36776
0 0 0 0 0 295192
3.728 1.664 0.428 0 0 0
0 5.918 2.964 0.876 0 0
0 0 5.060 5.164 1.793 0
0 0 0 13.224 8.723 3.671
0 0 0 0 17.235 13.224
] ] ] ] 0 20.808

Read the asset price tree as follows:

® Period 1 shows the up and down prices.

® Period 2 shows the up-up, up-down, and down-down prices.

® Period 3 shows the up-up-up, up-up, down-down, and down-down-down

prices.

e And so on.

2-17



2 Solving Problems with the Spreadsheet Link™ EX Software

Ignore the zeros. The option value tree gives the associated option value for
each node in the price tree. The option value is zero for prices significantly
above the exercise price. Ignore the zeros that correspond to a zero in the
price tree.

5 Try changing the data in B4:B10, and then executing the Spreadsheet Link
EX functions again.

Note If you increase the time to maturity (B7) or change the time
increment (B8), you may need to enlarge the output tree areas.

6 When you finish the example, close the figure window.
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Calculating and Plotting the Efficient Frontier of Financial

Portfolios

MATLAB and Financial Toolbox functions compute and plot risks, variances,
rates of return, and the efficient frontier of portfolios. Efficient portfolios have
the lowest aggregate variance, or risk, for a given return.Microsoft Excel

and the Spreadsheet Link EX software let you set up data, execute financial
functions and MATLAB graphics, and display numeric results.

This example analyzes three portfolios, using rates of return for six time
periods. In actual practice, these functions can analyze many portfolios over
many time periods, limited only by the amount of computer memory available.

This example is included in the Spreadsheet Link EX product. To run it:
1 Start Excel, Spreadsheet Link EX, and MATLAB sessions.

2 Navigate to the folder matlabroot\toolbox\exlink\.

3 Open the file Ex1iSamp.x1ls

4 Execute the example as needed.

Note This example requires Financial Toolbox, Statistics Toolbox, and
Optimization Toolbox.

1 Click the Sheet5 tab on Ex1iSamp.x1s. The worksheet for this example
appears.
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2-20

A B C D

Portfolio Efficient Frontier

Rates of return Global Corp. Bnd Small Cap
Nov-91| 7.125% 4.125% B8.375%
Nov-92| 5.125% 5125% 3.875%
MNov-93| -1.375% 5.750% 10.500%
MNov-94| 7.750% 6.000% 14.750%
Nov-95| 8.250% 6.375% -3.625%
MNov-96| 12.625% 6.125% 9.125%

Spreadsheet Link EX Functions
1. Transfer data to MATLAB.

F#MATLAB?
#MATLAB?

2. Execute MATLAB Financial Teolbox functions.
=== MLEvalString([ret, cov] = ewstatsiretseries)”)
=== NLEvalString([risk, ror, weights] = portopt(ret, cov, 20)")

F#MATLAB?
#MATLAB?

3. Transfer output data to Excel.

F#MATLAB?
F#MATLAB?
#MATLAB?

4. Plot efficient frontier data and label the figure.
=== [ILEvalString("portopt(ret, cov, 20); grid on; xlabel(Labels{1}); ylabel(Labels{2})")

F#MATLAB?

=== MLPutMatrix("Labels", F3:G3)
=== |ILPutMatrix("retseries”, B4:D9)

=== MLGetMatrix("risk”, "sheets!F47)
=== MLGetMatrix("ror”, "sheetb!G4™)
=== MLGetMatrix["weights”, "sheet5IH4")

Risk

ROR

H

Global
Weights

| d

Corp. Bnd Small Cap

2 Make A15 the active cell. Press F2; then press Enter. The Spreadsheet
Link EX function transfers the labels that describe the output that the

MATLAB software computes.

3 Make A16 the active cell to copy the portfolio return data to the MATLAB
workspace.

4 Execute the functions in A19 and A20 to compute the Financial Toolbox
efficient frontier function for 20 points along the frontier.

5 Execute the Spreadsheet Link EX functions in A23, A24, and A25 to copy

the output data to the Excel worksheet.

The worksheet looks as follows.



Calculating and Plotting the Efficient Frontier of Financial Portfolios

A B C D
1 |Portfolio Efficient Frontier
2
3 Rates of return Global Corp. Bnd Small Cap
4 Nov-91| 7.125% 4.125% B8.375%
5 Nov-92| 5.125% 5125% 3.875%
5 MNov-93| -1.375% 5.750% 10.500%
7 MNov-94| 7.750% 6.000% 14.750%
3 Nov-95| 8.250% 6.375% -3.625%
] MNov-96| 12.625% 6.125% 9.125%
10
11
12

12 Spreadsheet Link EX Functions
14 1. Transfer data to MATLAB.

15 0 === MLPutMatrix"Labels", F3:G3)
16 0 === MLPutMatrix{"retseries”, B4:D9)
17

18 2. Execute MATLAB Financial Toolbox functions.

19 0 === MLEvalString(ret, cov] = ewstatsiretseries)”) 3.262%| 6.846% 55.0% 0.0% 45.0%
20 0 === MLEvalString("[risk, ror, weights] = portopt(ret, cov, 20)7) 3.620%| 6.926% 41.3% 0.0% 58.7%
21 4.213%| 7.006% 27.5% 0.0% 72.5%
22 3. Transfer output data to Excel. 4.955%| 7.086% 13.8% 0.0% 86.2%
23 0 === MLGetMatrix("risk™, "sheet5IF47) 5.791%] 7.167% 0.0% 0.0%  100.0%
24 0 === MLGetMatrix("ror”, "sheet5!G4")

25 0 === MLGetMatrix("'weights”, "sheet5lH4")

26

27 |4. Plot efficient frontier data and label the figure.
28 |#MATLAB?

E E G H | J
Global Corp. Bnd Small Cap
Risk ROR Weights
0.730%| 5.643% 0.3% 96.1% 3.5%

0.760%| 5723% 40%  BO.7% £.3%
0.544%| 5.803% 77%  83.3% 9.0%
0.068%| 5883%| 11.3%  7EO%  11.8%
1113%| 5.964%| 15.0%  T0.5%  14.5%
1.287%| 6.044%| 187%  64.0%  17.3%
1.466%| 6.124%| 223%  57E%  20.0%
1653%| 6.204%| 26.0%  51.2%  228%
1.846%| B.284%| 207%  448%  255%
2042%| 6.365%| 33.3%  384%  28.3%
2241%| 6.445%| 37.0%  320% 31.1%
2443%| 6525%| 406%  256%  33.8%
2646%| B.605%| 443%  191%  36.6%
2850%| 6.685%| 48.0%  127%  39.3%
3.055%| 6.766%| 51.6% 6.3%  421%

=== [ILEvalString("portopt(ret, cov, 20); grid on; xlabel(Labels{1}); ylabel(Labels{2})")

The data describes the efficient frontier for these three portfolios: that set
of points representing the highest rate of return (ROR) for a given risk. For
each of the 20 points along the frontier, the weighted investment in each
portfolio (Weights) would achieve that rate of return.

6 Now move to A28 and press F2; then press Enter to execute the Financial
Toolbox function that plots the efficient frontier for the same portfolio data.

The following figure appears.
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Efficient Frontier EI@
File Edit View Inset Tools Desktop Window Help &
_bl—:'.ld;i [:E +x—x€-r?@ih-_£' @J DIE E
Mean-Variance-Efficient Frontier
0.074 T
0.072 — ----------------------------------------------------------
N
0.068 ----------- L
0.066 f-------=--- :
o= |
o \
o i
0.064 F----------- -
0.062----------- :
0.06 — e
0.058 [-------=-7-
0.056 ‘ ‘
0 0.01 0.02 0.03 0.04 0.05 0.06
Risk

The light blue line shows the efficient frontier. Note the change in slope
above a 6.8% return because the Corporate Bond portfolio no longer
contributes to the efficient frontier.

7 To try running this example using different data, close the figure window
and change the data in cells B4:D9. Then execute all the Spreadsheet Link
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EX functions again. The worksheet then shows the new frontier data, and
the MATLAB software displays a new efficient frontier graph.

When you finish this example, close the figure window.
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Mapping Time and Bond Cash Flows

2-24

This example shows how to use the Financial Toolbox and Spreadsheet Link
EX software to compute a set of cash flow amounts and dates, given a portfolio
of five bonds with known maturity dates and coupon rates. It is included in
the Spreadsheet Link EX product. To run it:

1 Start Excel, Spreadsheet Link EX, and MATLAB sessions.
2 Navigate to the folder matlabroot\toolbox\exlink\.
3 Open the file Ex1iSamp.x1ls

4 Execute the example as needed.

Note This example requires Financial Toolbox, Statistics Toolbox, and
Optimization Toolbox.

1 Click the Sheet6 tab on Ex1iSamp.x1s. The worksheet for this example
appears.



Mapping Time and Bond Cash Flows

(3|33 (2(a]e|w|N|o|n|» | w]n |

18

K L M N

Cash Flow Dates

Cash Flow Amounts

A B E D E F G H |
Cash Flow and Time Mapping for a Portfolio of Bonds

Settlement Date 26-Jul-99 Bond1

Bond2

Bond Data Bond3

Bond4

Maturity Coupon Rate Bond5
Bond1 15-Mov-99 0.05875
Bond2 15-May-00 0.06375
Bond3 15-Mov-00 0.08500
Bond4 15-May-01 0.08000
Bond5 15-Mov-01 015750

Bond1

Bond2

Spreadsheet Link EX Functions Bond3

1. Transfer data to MATLAB. Bond4

#MATLAB" «== MLPutMatrix("maturity”, Maturity’) Bond5

#MATLAB" <== MLPutMatrix("cpnrate”,"CpnRate")
#MATLAB' === MLPutMatrix("sd",C3)

2. Execute MATLAB Financial Toolbox Cash flow and Time mapping function.
#MATLAB® <== MLEvalString("md = x2mdate(maturity,0); sdm = x2mdate(sd.0)")
#MATLAB" <== MLEvalString("[cfa, cfd] = cfamounts(cpnrate, sdm, md, 2)")

3. Transform date numbers to string cell array.

#MATLAB" <== MLEvalString("i = find(isnan(cfd)); zcfd = cfd: zcfd(i) = 0: scfd=datestr{zcfd.2);")
#MATLAB" <== MLEvalstring("ccfd = num2cell{scfd,2); ccfd(i) = {N/AT; ccfd = reshape(ccfd, size(cfd)).”)
#MATLAB" «== MLEvalString("ccfa = cfa; ccfa(i) = 0; alldates = ccfd(end, :);")

4. Transfer output data to Excel.

#MATLAB' <== MLGetMatrix("ccfd", "sheet6li3")
#MATLAB <== MLGetMatrix("alldates”, "sheet6!i13")
#MATLAB' <== MLGetMatrix("ccfa”, "sheet6li14")

9. Plat the cash flow diagram.

#MATLAB" <== MLEvalString("cfploticfd, cfa); dtaxis(x",6.sdm.50):title(Cash Flow Diagram’);xlabel(Cash Flow Dates’).ylabel(Bonds’).")

2 Make A18 the active cell. Press F2, then Enter to execute the Spreadsheet
Link EX function that transfers the column vector Maturity to the

MATLAB workspace.

3 Make A19 the active cell to transfer the column vector Coupon Rate to the

MATLAB workspace.

4 Make A20 the active cell to transfer the settlement date to the MATLAB

workspace.

5 Execute the functions in cells A23 and A24 to enable the Financial Toolbox
software to compute cash flow amounts and dates.
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2-26

6 Now execute the functions in cells A27 through A29 to transform the dates
into string form contained in a cell array.

7 Execute the functions in cells A32 through A34 to transfer the data to the

Excel worksheet.

A B C D E
Cash Flow and Time Mapping for a Portfolio of Bonds
Settlement Date 26-Jul-99

Bond Data

Maturity Coupon Rate
Bond1 15-Mov-39 0.05875
Bond2 15-May-00 0.06375
Bond3 15-Mov-00 0.08500
Bond4 15-May-01 0.08000
Bond5 15-Mov-01 0.15750

Spreadsheet Link EX Functions

1. Transfer data to MATLAB.
0 === MLPutMatrix{"maturity”, Maturity’)
0 === MLPutMatrix("cpnrate”,"CpnRate")
0 === MLPutMatrix("sd",C3)

2. Execute MATLAB Financial Toolbox Cash flow and Time mapping function.
0 === MLEvalString("md = x2mdate(maturity,0); sdm = x2mdate(sd,0)")
0 === MLEvalString("[cfa, cfd] = cfamounts(cpnrate, sdm, md, 2)")

3. Transform date numbers to string cell array.

4. Transfer output data to Excel.

0 «== MLGetMatrix("ccfd", "sheetbli3")
0 === MLGetMatrix("alldates", "sheetfli13")
0 === MLGetMatrix{"ccfa", "shestfli14")

5. Plot the cash flow diagram.
#MATLAB’ === MLEvalString("cfplot(cfd, cfa); dtaxis(x.6,sdm,50):title(Cash Flow Diagram’).xlabel(Cash Flow Dates');ylabel(Bonds’);")

Bond1
Bond2
Bond3
Bond4
Bond5

Bond1
Bond2
Bond3
Bond4
Bond5

7/26/1999
7/26/1999
7/26/1999
7/26/1999
7/26/1999

J K L M N
Cash Flow Dates

11/15/1999  N/A MIA MIA NiA

11/15/1999 5/15/2000 MIA MIA NiA

11/15/1999 5/15/2000 11/15/2000  MN/A NiA

11/15/1999 5/15/2000 11/15/2000 5/M15/2001 NiA

11/15/1999 5/15/2000 11/15/2000 5/15/2001 11/15/2001

Cash Flow Amounts

7/26/1999 11/15/1999 5/15/2000 11/15/2000 5/15/2001 11/15/2001
-1.1495  102.9375 0 0 0 0
-1.2473 3.1875  103.1875 0 0 0
-1.6630 4.2500 42500 104.2500 0 0
-1.5652 4.0000 4.0000 4.0000  104.0000 0
-3.0815 7.8750 7.8750 78750 7.8750  107.8750

0 <== MLEvalString("i = find(isnan(cfd)); zcfd = cfd; zcfd(i) = 0; scfd=datestr(zcfd.2).")
0 === MLEvalstring{"ccfd = num2cell{scfd,2); ccfd(i) = {N/AT; ccfd = reshape(cefd, size(cfd));")
0 «== MLEvalString("ccfa = cfa; ccfa(i) = 0; alldates = ccfdiend, :):")

8 Finally, execute the function in cell A37 to display a plot of the cash flows

for each portfolio item.




Mapping Time and Bond Cash Flows

9 When you finish the example, close the figure window.
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Error Messages and
Troubleshooting

o “Worksheet Cell Errors” on page 3-2
e “Microsoft® Excel Errors” on page 3-5
e “Data Errors” on page 3-8

e “Startup Errors” on page 3-10

e “Audible Error Signals” on page 3-10



3 Error Messages and Troubleshooting

Worksheet Cell Errors

You may see these error messages displayed in a worksheet cell.
The first column of the following table contains worksheet cell error messages.
The error messages begin with the number sign (#). Most end with an

exclamation point (!) or with a question mark (?).

Worksheet Cell Error Messages

Worksheet Cell

Error Message Meaning Solution

#COLS>#MAXCOLS! Your MATLAB variable exceeds | This is a limitation in the Excel
the Microsoft Excel limit of product. Try the computation
#MAXCOLS! columns. with a variable containing fewer

columns.

#COMMAND ! The MATLAB software does not | Verify the spelling of the MATLAB
recognize the command in an command. Correct typing errors.
MLEvalString function. The
command may be misspelled.

#DIMENSION! You used MLAppendMatrix and Verify the matrix dimensions and
the dimensions of the appended | the appended data dimensions,
data do not match the dimensions | and correct the argument.
of the matrix you want to append. | For more information, see the

MLAppendMatrix reference page.

#INVALIDNAME! You entered an illegal variable Make sure to use legal MATLAB

name. variable names. MATLAB
variable names must start with a
letter followed by up to 30 letters,
digits, or underscores.

#INVALIDTYPE! You have specified an illegal For a list of supported MATLAB
MATLAB data type with data types, see “Classes (Data
MLGetVar or MLGetMatrix. Types)” in the MATLAB

Programming Fundamentals
documentation.




Worksheet Cell Errors

Worksheet Cell Error Messages (Continued)

Worksheet Cell

Error Message Meaning Solution

#MATLAB? You used a Spreadsheet Link Start the Spreadsheet Link EX
EX function and no MATLAB and MATLAB software. See
software session is running. “Starting and Stopping the

Spreadsheet Link EX Software”
on page 1-17.

#NAME? The function name is Be sure the excllink.xla add-in
unrecognized. The excllink.xla | is loaded. See “Configuring the
add-in is not loaded, or the Spreadsheet Link EX Software”
function name may be misspelled. | on page 1-7. Check the spelling of

the function name. Correct typing
errors.

#NONEXIST! You referenced a nonexistent Verify the spelling of the MATLAB
matrix in an MLGetMatrix or matrix. Use the MATLAB whos
MLDeleteMatrix function. The command to display existing
matrix name may be misspelled. | matrices. Correct typing errors.

#ROWS>#MAXROWS ! Your MATLAB variable exceeds | This is a limitation in the Excel
the Excel limit of #MAXROWS!! product. Try the computation
TrOWS. with a variable containing fewer

rOwsS.

#SYNTAX? You entered a Spreadsheet Verify and correct the function

Link EX function with incorrect
syntax. For example, you did not
specify double quotation marks
(") , or you specified single
quotation marks () instead of
double quotation marks.

syntax. For more information,
see Chapter 5, “Functions —
Alphabetical List”.
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Worksheet Cell Error Messages (Continued)

Worksheet Cell

Error Message Meaning Solution

#VALUE ! An argument is missing from a Supply the correct number of
function, or a function argument | function arguments, of the correct
1is the wrong type. type.

#VALUE! A macro subroutine uses Since the function works correctly,

MLGetMatrix followed by
MatlabRequest, which is correct
standard usage. A macro function

ignore the message. Or, in
this special case, remove
MatlabRequest from the

calls that subroutine, and you subroutine.
execute that function from a
worksheet cell. The function
works correctly, but this message

appears in the cell.

Note When you open an Excel worksheet that contains Spreadsheet Link EX
functions, the Excel software tries to execute the functions from the bottom up
and right to left. Excel may generate cell error messages such as #COMMAND !
or #NONEXIST!. This is expected behavior. Do the following:

1 Ignore the messages.
2 Close MATLAB figure windows.

3 Reexecute the cell functions one at a time in the correct order by pressing
F2, and then Enter.
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Microsoft Excel Errors

The Excel software may display one of the following error messages.

Excel Error Messages

Error Message

Cause of Error

Solution

Error in formula

You entered a formula
incorrectly. Common errors
include a space between the
function name and the left
parenthesis; or missing, extra,
or mismatched parentheses.

Check entry and correct typing
errors.

Can't find project or
library

You tried to execute a
macro and the location of
excllink.xla is incorrect.

Click OK. The References
window opens. Remove

the check from MISSING:
excllink.xla. Find
excllink.xla in its correct
location, select its check box in

the References window, and
click OK.

Run-time error '1004':
Cells method of

Application class failed

You used MLGetMatrix and the
matrix is larger than the space
available in the worksheet.
This error destabilizes the
Spreadsheet Link EX software
session and changes worksheet
calculation mode to manual.

Click OK. Reset worksheet
calculation mode to
automatic, and save your
worksheet as needed. Restart
the Excel, Spreadsheet Link
EX, and MATLAB software
sessions.
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Excel Error Messages (Continued)

Error Message

Cause of Error

Solution

MATLAB failed to
check out a license
of Spreadsheet Link
EX or does not have a
valid installation of
Spreadsheet Link EX

You entered an invalid
license passcode or did not
install Spreadsheet Link EX
properly.

Check that you entered the
license passcode properly.
Reinstall the Spreadsheet
Link EX add-on. (See
“Installing the Spreadsheet
Link EX Software” on page
1-4.) If you followed the
installation guidelines, used
a proper passcode and you
are still unable to start the
Spreadsheet Link EX software,
contact your MathWorks
representative.

Datasource: Excel;
prompt for user name
and password

This message appears when an
attempt to connect to the Excel
software from the Database
Toolbox™ software fails.

Make sure that the Excel
spreadsheet referenced by the
data source exists, then retry
the connection.




Microsoft® Excel® Errors

Excel Error Message Boxes

Error Message Box Cause of Error Solution

Microsoft Visual Basic

Run-time error '429';

ActiveX component can't create object

End

Help

This error appears
when you start
the automation
server from the
Excel interface,
and multiple
versions of the
MATLAB software
are installed on
your desktop.

To correct this error, perform the
following:

1 Shut down all MATLAB and Excel
instances.

2 Open a Command Prompt window,
and using cd, change to the bin\win32
subfolder of the MATLAB installation
folder.

3 Type the command:

.\matlab /regserver

4 When the MATLAB session starts, close
it. Using /regserver fixes the registry
entries.

5 Start an Excel session. The Spreadsheet
Link EX add-in now loads properly.

6 Verify that the Spreadsheet Link EX
software 1s working by entering the
following command from the MATLAB
Command Window:

a = 3.14159

7 Enter the following formula in cell A1 of
the open Excel worksheet:

=mlgetmatrix("a","atl")

8 The value 3.14159 appears in cell A1.
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Data Errors

In this section...

“Matrix Data Errors” on page 3-8

“Errors When Opening Saved Worksheets” on page 3-8

Matrix Data Errors

Data in the MATLAB or Microsoft Excel workspaces may produce the
following errors.

Data Errors

Data Error

Cause

Solution

MATLAB matrix cells
contain zeros (0).

Corresponding Excel worksheet
cells are empty.

Excel worksheet cells must
contain only numeric or string
data.

MATLAB matrix is a
1-by-1 zero matrix.

You used quotation marks
around the data-location
argument in MLPutMatrix or
MLAppendMatrix.

Correct the syntax to remove
quotation marks.

MATLAB matrix is
empty ([ 1).

You referenced a nonexistent
VBA variable in MLPutVar.

Correct the macro; you may
have typed the variable name
incorrectly.

VBA matrix is empty.

You referenced a nonexistent
MATLAB variable in MLGetVar.

Correct the macro; you may
have typed the variable name
incorrectly.

Errors When Opening Saved Worksheets

This section describes errors that you may encounter when opening saved
worksheets.

® When you open an Excel worksheet that contains Spreadsheet Link EX
functions, the Excel software tries to execute the functions from the bottom



Data Errors

up and right to left. Excel may generate cell error messages such as
#COMMAND ! or #NONEXIST!. This is expected behavior. Do the following:

1 Ignore the messages.
2 Close MATLAB figure windows.

3 Reexecute the cell functions one at a time in the correct order by pressing
F2, and then Enter.

If you save an Excel worksheet containing Spreadsheet Link EX functions,
and then reopen it in an environment where the excllink.xla add-in is in
a different location, you may see the message: This document contains
links: Re-establish links?

To address this issue, do the following:

1 Click No.

Select Edit > Links.

In the Links dialog box, click Change Source.

Hh WO DN

In the Change Links dialog box, select
matlabroot\toolbox\exlink\excllink.xla.

5 Click OK.

The Excel software executes each function as it changes its link. You
may see MATLAB figure windows and hear error beeps as the links
change and functions execute; ignore them.

6 In the Links dialog box, click OK.

The worksheet now connects to the Spreadsheet Link EX add-in.

Or, instead of using the Links menu, you can manually edit the link
location in each affected worksheet cell to show the correct location of
excllink.xla.

3-9
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Startup Errors

If you have enabled MLAutoStart, double-clicking an x1s file in the MATLAB
Current Folder browser and choosing Open Outside MATLAB causes a
Microsoft Excel error to appear. To open the file successfully, click End in
the error window.

To avoid this issue, disable MLAutoStart. Start MATLAB sessions from the
Excel interface by clicking the startmatlab button in the Excel menu bar.

Audible Error Signals

You may hear audible errors while passing data to the MATLAB workspace
using MLPutMatrix or MLAppendMatrix. These errors usually indicate that
you have insufficient computer memory to carry out the operation. Close other
applications or clear unnecessary variables from the MATLAB workspace and
try again. If the error signal reoccurs, you probably have insufficient physical
memory in your computer for this operation.



Function Reference

Link Management (p. 4-2) Work with link management
functions
Data Management (p. 4-3) Work with data management

functions
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Link Management

matlabinit
MLAutoStart

MLClose
MLOpen
MLUseCellArray

Initialize Spreadsheet Link EX
software and start MATLAB process

Automatically start MATLAB
process

Stop MATLAB process
Start MATLAB process

Toggle MLPutMatrix to use MATLAB
cell arrays



Data Management

Data Management

matlabfcn

matlabsub
MLAppendMatrix
MLDeleteMatrix
MLEvalString
MLGetFigure
MLGetMatrix
MLGetVar
MLMissingDataAsNaN
MLPutMatrix

MLPutVar

MLShowMatlabErrors

Evaluate MATLAB command given
Microsoft Excel data

Evaluate MATLAB command given
Microsoft Excel data and designate
output location

Create or append MATLAB matrix
with data from Microsoft Excel
worksheet

Delete MATLAB matrix

Evaluate command in MATLAB
software

Import current MATLAB figure into
Microsoft Excel spreadsheet

Write contents of MATLAB matrix
to Microsoft Excel worksheet

Write contents of MATLAB matrix
in Microsoft Excel VBA variable

Set empty cells to NaN or 0

Create or overwrite MATLAB matrix
with data from Microsoft Excel
worksheet

Create or overwrite MATLAB matrix

with data from Microsoft Excel VBA
variable

Return standard Spreadsheet Link
EX errors or full MATLAB errors
using MLEvalString
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MLStartDir Specify MATLAB current working
folder after startup

MLUseFullDesktop Specify whether to use full MATLAB
desktop or MATLAB Command
Window

4-4
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matlabfcn

Purpose

Syntax

Description

Examples

See Also

Evaluate MATLAB command given Microsoft Excel data

Worksheet: matlabfcn(command, inputs)

command MATLAB command to evaluate. Embed the command
in double quotation marks; for example, "command".

inputs Variable length input argument list passed to a
MATLAB command. The argument list may contain
a range of worksheet cells that contain input data.

Passes the command to the MATLAB workspace for evaluation, given
the function input data. The function returns a single value or string
depending upon the MATLAB output. The result is returned to the
calling worksheet cell. This function is intended for use as an Excel
worksheet function.

1 Add the data in worksheet cells B1 through B10, and then return the
sum to the active worksheet cell:

matlabfcn("sum", B1:B10)

2 Plot the data in worksheet cells B1 through B10, using x as the
marker type:

matlabfcn("plot", B1:B10, "x")

matlabsub



matlabinit

Purpose

Syntax

Description

See Also

Initialize Spreadsheet Link EX software and start MATLAB process

matlabinit

Note To run matlabinit from the Microsoft Excel toolbar, click
Tools > Macro. In the Macro Name/Reference box, enter
matlabinit and click Run. Alternatively, you could include this
function in a macro subroutine. You cannot run matlabinit as a
worksheet cell formula or in a macro function.

Initializes the Spreadsheet Link EX software and starts MATLAB
process. If the Spreadsheet Link EX software has been initialized and
the MATLAB software is running, subsequent invocations do nothing.
Use matlabinit to start Spreadsheet Link EX and MATLAB sessions
manually when you have set MLAutoStart to no. If you set MLAutoStart
to yes, matlabinit executes automatically.

MLAutoStart | MLOpen
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Purpose

Syntax

Description

Evaluate MATLAB command given Microsoft Excel data and designate

output location

Worksheet:

command

edat

inputs

matlabsub(command, edat, inputs)

MATLAB command to evaluate. Enter the
MATLAB command in double quotation marks,
as "command".

Worksheet location where the function writes
the returned data. "edat" (in quotation marks)
directly specifies the location and it must be a
cell address or a range name. edat (without
quotation marks) is an indirect reference: the
function evaluates the contents of edat to get the
location. edat must be a worksheet cell address or
range name. Although you can specify a range of
output cells, matlabsub does not support multiple
outputs. Instead of returning multiple outputs,
matlabsub returns the first output starting in the
first cell from the specified range, and discards
all other outputs.

Variable length input argument list passed to
MATLAB command. This argument list can
contain a range of worksheet cells that contain
input data.

Passes the specified command to the MATLAB workspace for
evaluation, given the function input data. The function returns a single
value or string depending upon the MATLAB output. This function is
intended for use as an Excel worksheet function.

To return an array of data to the Microsoft Excel Visual Basic for
Applications (VBA) workspace, see MLEvalString and MLGetVar.



matlabsub

Caution edat must not include the cell that contains the matlabsub
function. In other words, be careful not to overwrite the function itself.
Also make sure there is enough room in the worksheet to write the
matrix contents. If there is insufficient room, the function generates a
fatal error.

Examples Sum the data in worksheet cells B1 through B10, and then return the
output to cell A1:

matlabsub("sum", "A1", B1:B10)

See Also matlabfcn
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5-6

Purpose

Syntax

Description

Create or append MATLAB matrix with data from Microsoft Excel

worksheet

Worksheet:
Macro:

var_name

mdat

MLAppendMatrix(var_name, mdat)
MLAppendMatrix var_name, mdat

Name of MATLAB matrix to which to append
data. "var_name" (in quotation marks) directly
specifies the matrix name. var_name (without
quotation marks) is an indirect reference: the
function evaluates the contents of var_name to
get the matrix name, and var_name must be a
worksheet cell address or range name

Location of data to append to var_name. mdat
(no quotation marks). Must be a worksheet cell
address or range name.

If this argument is not initially an Excel Range
data type and you call the function from a
worksheet, MLAppendMatrix performs the
necessary type coercion.

If this argument is not an Excel Range data
type and you call the function from within a
Microsoft Visual Basic macro, the call fails. The
error message ByRef Argument Type Mismatch
appears.

Appends data in mdat to MATLAB matrix var_name. Creates var_name

if it does not exist. The function checks the dimensions of var_name and
mdat to determine how to append mdat to var_name. If the dimensions
allow appending mdat as either new rows or new columns, it appends
mdat to var_name as new rows. If the dimensions do not match, the

function returns an error. mdat must contain either numeric data or

string data. Data types cannot be combined within the range specified



MLAppendMatrix

Examples

See Also

in mdat. Empty mdat cells become MATLAB matrix elements containing
zero if the data is numeric, and empty strings if the data is a string.

Example 1: Append data from a worksheet cell range to
a MATLAB matrix

In this example, B is a 2-by-2 MATLAB matrix. Append the data in
worksheet cell range A1:A2 to B:

MLAppendMatrix("B", A1:A2)

Al

A2

B is now a 2-by-3 matrix with the data from A1:A2 in the third column.

Example 2: Append data from a named worksheet cell
range to a MATLAB matrix

B is a 2-by-2 MATLAB matrix. Cell C1 contains the label (string) B,
and new_data is the name of the cell range A1:B2. Append the data in
cell range A1:B2 to B:

MLAppendMatrix(C1, new_data)

B is now a 4-by-2 matrix with the data from A1:B2 in the last two rows.

Al B1
A2 B2
MLPutMatrix



MLAutoStart

Purpose

Syntax

Description

Examples

See Also

Automatically start MATLAB process

Worksheet: MLAutoStart("yes")
MLAutoStart("no")

Macro: MLAutoStart "yes"
MLAutoStart "no"
"yes" Automatically start the Spreadsheet Link EX and

MATLAB software every time a Microsoft Excel
session starts (default).

"no" Cancel automatic startup of the Spreadsheet Link
EX and MATLAB software. If these products are
running, it does not stop them.

Sets automatic startup of the Spreadsheet Link EX and MATLAB
software. When the Spreadsheet Link EX software is installed, the
default is yes. A change of state takes effect the next time an Excel
session starts.

Cancel automatic startup of the Spreadsheet Link EX and MATLAB
software:

MLAutoStart("no")

These products do not start on subsequent Excel session invocations.

matlabinit | MLClose | MLOpen



MLClose

Purpose

Syntax

Description

See Also

Stop MATLAB process

Worksheet: MLClose()

Macro: MLClose

Ends the MATLAB process, deletes all variables from the MATLAB
workspace, and tells the Microsoft Excel software that the MATLAB
software is no longer running. If no MATLAB process is running,
nothing happens.

MLOpen
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Purpose Delete MATLAB matrix
Syntax
Worksheet: MLDeleteMatrix(var_name)
Macro: MLDeleteMatrix var_name
var_name Name of MATLAB matrix to delete. "var_name"

(in quotation marks) directly specifies the matrix
name. var_name (without quotation marks) is

an indirect reference: the function evaluates the
contents of var_name to determine the matrix name,
and var_name must be a worksheet cell address or
range name.

Description Deletes the named matrix from the MATLAB workspace.

Examples Delete matrix A from the MATLAB workspace:

MLDeleteMatrix ("A")



MLEvalString

Purpose

Syntax

Description

Examples

See Also

Evaluate command in MATLAB software

Worksheet: MLEvalString(command)
Macro: MLEvalString command
command MATLAB command to evaluate. "command" (in

quotation marks) directly specifies the command.
command (without quotation marks) is an indirect
reference: the function evaluates the contents of
command to get the command, and command must be
a worksheet cell address or range name.

Passes a command string to the MATLAB software for evaluation. The
specified action alters only the MATLAB workspace. It has no effect
on the Microsoft Excel workspace.

Divide the MATLAB variable b by 2, and then plot it:
MLEvalString("b = b/2;plot(b)")

This command only modifies the MATLAB variable b. To update data
in the Excel worksheet, use MLGetMatrix.

MLGetMatrix

5-11



MLGetFigure

Purpose Import current MATLAB figure into Microsoft Excel spreadsheet
Syntax
Worksheet: MLGetFigure(width,height)
Macro: MLGetFigure width, height
width Specify the width in normalized units of the
MATLAB figure when imported into an Excel
worksheet.
height Specify the height in normalized units of the
MATLAB figure when imported into an Excel
worksheet.
Description Import the current MATLAB figure into an Excel worksheet, where the

top-left corner of the figure is the current spreadsheet cell.

If worksheet calculation mode is automatic, MLGetFigure executes
when you enter the formula in a cell. If worksheet calculation mode
is manual, enter the MLGetFigure function in a cell, then press F9 to
execute it. However, pressing F9 in this situation may also reexecute
other worksheet functions and generate unpredictable results.

If you use MLGetFigure in a macro subroutine, enter MatlabRequest
on the line after the MLGetFigure. MatlabRequest initializes internal
Spreadsheet Link EX variables and enables MLGetFigure to function in
a subroutine. Do not include MatlabRequest in a macro function unless
the function is called from a subroutine.

Examples Import the current MATLAB figure into an Excel worksheet. Adjust the

width of the figure to be half that of the original figure, and the height
to be a quarter that of the original figure:

MLGetFigure(.50,.25)

See Also MLGetMatrix | MLGetVar
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MLGetMatrix

Purpose

Syntax

Description

Write contents of MATLAB matrix to Microsoft Excel worksheet

Worksheet:
Macro:

var_name

edat

MLGetMatrix(var_name, edat)
MLGetMatrix var_name, edat

Name of MATLAB matrix to access."var_name" (in
quotation marks) directly specifies the matrix name.
var_name (without quotation marks) is an indirect
reference: the function evaluates the contents of
var_name to get the matrix name, and var_name
must be a worksheet cell address or range name.
var_name cannot be the MATLAB variable ans.

Worksheet location where the function writes the
contents of var_name. "edat" (in quotation marks)
directly specifies the location and it must be a cell
address or a range name. edat (without quotation
marks) is an indirect reference: the function
evaluates the contents of edat to get the location,
and edat must be a worksheet cell address or range
name.

Writes the contents of MATLAB matrix var_name in the Excel
worksheet, beginning in the upper-left cell specified by edat. If

data exists in the specified worksheet cells, it is overwritten. If the
dimensions of the MATLAB matrix are larger than that of the specified
cells, the data overflows into additional rows and columns.

Caution

edat must not include the cell that contains the MLGetMatrix function.

In other words, be careful not to overwrite the function itself. Also make
sure there is enough room in the worksheet to write the matrix contents.
If there is insufficient room, the function generates a fatal error.
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MLGetMatrix function does not automatically adjust cell addresses. If
edat is an explicit cell address, edit it to correct the address when you
do either of the following:

¢ Insert or delete rows or columns.

e Move or copy the function to another cell.

If worksheet calculation mode is automatic, MLGetMatrix executes
when you enter the formula in a cell. If worksheet calculation mode is
manual, enter the MLGetMatrix function in a cell, and then press F9 to

execute it. However, pressing F9 in this situation may also reexecute
other worksheet functions and generate unpredictable results.

If you use MLGetMatrix in a macro subroutine, enter MatlabRequest
on the line after the MLGetMatrix. MatlabRequest initializes internal
Spreadsheet Link EX variables and enables MLGetMatrix to function in
a subroutine. Do not include MatlabRequest in a macro function unless
the function is called from a subroutine.

Examples Example 1

Write the contents of the MATLAB matrix bonds starting in cell C10 of
Sheet2. If bonds is a 4-by-3 matrix, fill cells C10. .E13 with data:

MLGetMatrix("bonds", "Sheet2!C10")

Example 2

Access the MATLAB matrix named by the string in worksheet cell
B12. Write the contents of the matrix to the worksheet starting at the
location named by the string in worksheet cell B13:

MLGetMatrix (B12, B13)

Example 3

Write the contents of MATLAB matrix A to the worksheet, starting at
the cell named by RangeA:

5-14



MLGetMatrix

See Also

Sub Get_RangeA()
MLGetMatrix "A", "RangeA"
MatlabRequest

End Sub

Example 4
In a macro, use the Address property of the range object returned by
the VBA Cells function to specify where to write the data:

Sub Get_Variable()

MLGetMatrix "X", Cells(3, 2).Address
MatlabRequest

End Sub

MLAppendMatrix | MLPutMatrix
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Purpose

Syntax

Description

Examples

See Also

Write contents of MATLAB matrix in Microsoft Excel VBA variable

MLGetVar ML_var_name, VBA_var_name

ML_var_name

VBA_var_name

Name of MATLAB matrix to access.
"ML_var_name" (in quotation marks) directly
specifies the matrix name. ML_var_name
(without quotation marks) is an indirect
reference: the function evaluates the contents
of ML_var_name to get the matrix name,

and ML_var_name must be a VBA variable
containing the matrix name as a string.
var_name cannot be the MATLAB variable
ans. If defined, ML_var_name should be of type
VARIANT. Any other type will give a "TYPE
MISMATCH" error.

Name of VBA variable where the function
writes the contents of ML_var_name. Use
VBA_var_name without quotation marks.

Writes the contents of MATLAB matrix ML_var_name in the
Excel Visual Basic for Applications (VBA) variable VBA_var_name.
Creates VBA_var_name if it does not exist. Replaces existing data in

VBA_var_name.

Write the contents of the MATLAB matrix J into the VBA variable

Datad:

Sub Fetch()

MLGetVar "J", Datad

End Sub

MLPutVar



MLMissingDataAsNaN

Purpose

Syntax

Description

Examples

See Also

Set empty cells to NaN or 0

Worksheet: MLMissingDataAsNaN("yes")
MLMissingDataAsNaN("no") (Default)
Macro: MLMissingDataAsNaN "yes"
MLMissingDataAsNaN "no" (Default)
"yes" Sets empty cells to use NaNs.

"no" Sets empty cells to use 0s. (Default)

Sets empty cells to NaN or 0. When the Spreadsheet Link EX software is
installed, the default is "no", so empty cells are handled as 0s. If you
change the value of MLUseCellArray to "yes", the change remains in
effect the next time a Microsoft Excel session starts.

Note A string in an Excel range always forces cell array output and
empty cells as NaNs.

Cancel the use of the value NaN for empty cells:

MLMissingDataAsNaN('no")

MLPutMatrix
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Purpose

Syntax

Description

Examples

See Also

Start MATLAB process

Worksheet: MLOpen ()

Macro: MLOpen

Starts MATLAB process. If a MATLAB process has already started,
subsequent calls to MLOpen do nothing. Use MLOpen to restart the
MATLAB session after you have stopped it with MLClose in a given
Microsoft Excel session.

Note We recommend using matlabinit rather than MLOpen, since
matlabinit starts a MATLAB session and initializes the Spreadsheet
Link EX software.

Starts a MATLAB session:

MLOpen ()

matlabinit | MLClose



MLPutMatrix

Purpose

Syntax

Description

Create or overwrite MATLAB matrix with data from Microsoft Excel
worksheet

Worksheet: MLPutMatrix(var_name, mdat)
Macro: MLPutMatrix var_name, mdat

var_name Name of MATLAB matrix to create or overwrite.
"var_name" (in quotation marks) directly specifies the
matrix name. var_name (without quotation marks)
is an indirect reference: the function evaluates the
contents of var_name to get the matrix name, and
var_name must be a worksheet cell address or range
name.

mdat Location of data to copy into var_name. mdat (no
quotation marks). Must be a worksheet cell address
or range name.

Creates or overwrites matrix var_name in MATLAB workspace with
specified data in mdat. Creates var_name if it does not exist. If var_name
exists, this function replaces the contents with mdat. Empty numeric
data cells within the range of mdat become numeric zeros within the
MATLAB matrix identified by var_name.

If any element of mdat contains string data, mdat is exported as a
MATLAB cell array. Empty string elements within the range of mdat
become NaNs within the MATLAB cell array.

When using MLPutMatrix in a subroutine, indicate the source of the
worksheet data using the Microsoft Excel macro Range. For example:

Sub test()
MLPutMatrix "a", Range("A1:A3")
End Sub

If you have a named range in your worksheet, you can specify the name
instead of the range; for example:
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Sub test()
MLPutMatrix "a", Range("temp")
End Sub

where temp is a named range in your worksheet.

Examples Example 1 — Create or overwrite a matrix in the MATLAB
workspace

Create or overwrite matrix A in the MATLAB workspace with the data
in the worksheet range A1:C3:

MLPutMatrix "A", Range("A1:C3")

Example 2 — Use the putmatrix toolbar button to import
data from a Microsoft Excel worksheet to the MATLAB
workspace

Use the putmatrix toolbar button to import data from an Excel
worksheet to the MATLAB workspace:

1 In the Excel worksheet, select the columns and/or rows you want to
export to the MATLAB workspace.

@il 9o

Home Insert Page Layout Formulas Data

startmatlab |putmatrix  getmatrix evalstring getfigure wizard preferences

Custom Toolbars

3 1 2 3
4 4 3 B
5
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2 Click the putmatrix button on the Spreadsheet Link EX toolbar.
A window appears that prompts you to specify the name of the
MATLAB variable in which you want to store your data.

Microsoft Excel @

Variable name in MATLAB
Cancel

-

3 Enter newmatrix for the MATLAB variable name.

4 Click OK.
Now you can manipulate newmatrix in the MATLAB Command
Window.
newmatrix
newmatrix =
1 2 3
4 5 6
See Also MLAppendMatrix | MLGetMatrix
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Purpose

Syntax

Description

Examples

5-22

Create or overwrite MATLAB matrix with data from Microsoft Excel

VBA variable

MLPutVar ML_var_name, VBA_var_name

ML_var_name

VBA_var_name

Name of MATLAB matrix to create or overwrite.
"ML_var_name" (in quotation marks) directly
specifies the matrix name. ML_var_name (without
quotation marks) is an indirect reference: the
function evaluates the contents of ML_var_name
to get the matrix name, and ML_var_name must
be a VBA variable containing the matrix name
as a string.

Name of VBA variable whose contents are written
to ML_var_name. Use VBA var_name without
quotation marks.

Creates or overwrites matrix ML_var_name in MATLAB workspace with
data in VBA_var_name. Creates ML_var_name if it does not exist. If
ML_var_name exists, this function replaces the contents with data from
VBA_var_name. Use MLPutVar only in a macro subroutine, not in a
macro function or in a subroutine called by a function.

Empty numeric data cells within VBA_var_name become numeric zeros
within the MATLAB matrix identified by ML_var_name.

If any element of VBA var_name contains string data, VBA_var_name
is exported as a MATLAB cell array. Empty string elements within
VBA_var_name become NaNs within the MATLAB cell array.

Create (or overwrite) the MATLAB matrix K with the data in the Excel
Visual Basic for Applications (VBA) variable DataKk.

Sub Put()

MLPutvar "K', DataK



MLPutVar
|

End Sub

See Also MLGetVar
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Purpose

Syntax

Description

Examples

See Also

Return standard Spreadsheet Link EX errors or full MATLAB errors
using MLEvalString

Worksheet: MLShowMatlabErrors("yes")
MLShowMatlabErrors("no") (Default)
Macro: MLShowMatlabErrors "yes"

MLShowMatlabErrors "no" (Default)

"yes" Displays the full MATLAB error string upon
MLEvalString failure.

"no" Displays the standard Spreadsheet Link EX errors
upon MLEvalString failure.

Sets the Spreadsheet Link EX error display mode when executing
MATLAB commands using MLEvalString.

e Cause MLEvalString failures to show standard Spreadsheet Link EX
errors, such as #COMMAND.

MLShowMatlabErrors("no")

¢ Cause MLEvalString failures to show MATLAB error strings, such
as ??? Undefined function or variable 'foo'.

MLShowMatlabErrors("yes")

MLEvalString



MLStartDir

Purpose

Syntax

Description

Examples

See Also

Specify MATLAB current working folder after startup

Worksheet: MLStartDir(path)

Macro: MLStartDir path

path Specify the current MATLAB working folder after
startup.

Sets the MATLAB working folder after startup. This function does not
work like the standard Microsoft Windows Start In setting, because it
does not automatically run startup.m or matlabrc.min the specified
folder.

Note The working folder changes only if you run MATLAB after you
run this function. Running this function while MATLAB is running
does not change the working folder for the current session. In this
case, MATLAB uses the specified folder as the working folder when
it is restarted.

Set the MATLAB working folder to d: \work after startup:

MLStartDir ( d:\work )
If your folder path includes a space, embed the path in single quotation
marks within double quotation marks. For example, to set the MATLAB

working folder to d:\my work, run the command:

MLStartDir ( 'd:\my work' )

MLAutoStart
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MLUseCellArray

Purpose

Syntax

Description

Examples

See Also

5-26

Toggle MLPutMatrix to use MATLAB cell arrays

Worksheet: MLUseCellArray("yes")
MLUseCellArray ("no")

Macro: MLUseCellArray "yes"
MLUseCellArray "no"

"yes" Automatically uses cell arrays for transfer of data
structures.

"no" Do not automatically use cell arrays for transfer of

data (default).

Using MLUseCellArray forces MLPutMatrix to use cell arrays for
transfer of data (for example, dates). When the Spreadsheet Link EX
software is installed, the default is "no". If you change the value of
MLUseCellArray to "yes", the change remains in effect the next time
a Microsoft Excel session starts.

Cancel automatic use of cell arrays for easy transfer of data:

MLUseCellArray("no")

MLPutMatrix



MLUseFullDesktop

Purpose

Syntax

Description

Examples

See Also

Specify whether to use full MATLAB desktop or MATLAB Command
Window

Worksheet: MLUseFullDesktop("yes")
MLUseFullDesktop("no")

Macro: MLUseFullDesktop "yes"
MLUseFullDesktop "no"

"yes" Start full MATLAB desktop.
"no" Start the MATLAB Command Window only.

Sets the MATLAB session to start with the full desktop or Command
Window only. When the Spreadsheet Link EX software is installed,
the default is "yes".

Start only the MATLAB Command Window:

MLUseFullDesktop("no")

matlabinit | MLClose | MLOpen
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Examples

Use this list to find examples in the documentation.



Examples

Macro Examples

“Sending MATLAB Data to an Excel Worksheet and Displaying the
Results” on page 1-30

“Importing and Exporting Data Between the Microsoft® Excel Interface
and the MATLAB Workspace” on page 1-33

Financial Examples

“Modeling Data Sets Using Data Regression and Curve Fitting” on page 2-2
“Interpolating Data” on page 2-11

“Pricing Stock Options Using the Binomial Model” on page 2-15
“Calculating and Plotting the Efficient Frontier of Financial Portfolios”

on page 2-19

“Mapping Time and Bond Cash Flows” on page 2-24
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